Author Topic: Technical support for Relic of the Viking  (Read 4919 times)

Offline jeancallisti

  • Lead Artist
  • *****
  • Posts: 2179
  • I love Indy
    • View Profile
Technical support for Relic of the Viking
« on: January 03, 2020, 11:17:35 pm »
This is the list of known issues :

000 Floating hotspot not disabled during various actions. In particular while Indy talks after a "look at" or other actions
001 "Use" followed by a click on inventory item acts as "Interact with item" instead of starting "Use item with...". This behaviour is not present in Tumbleweed, on which our system is based.
002 check why warning.log tells us that we don't have writing permissions "C:\PROGRA~3\Adventure Game Studio/Indiana Jones and the relic of the viking/' " FIXED: Inserted $GAMEDATADIR$ into the log file's path.
003 Cannot set game icon when building.
004 Indy walks too fast (?)
005 Indy doesn't have his iconic whip. If we give it to him it makes the Paddling Oar useless.
006 Capitalize "Viking" in game name and Disclaimer
007 Disclaimer typo: Our team of contributors is Meh. I changed it beause I'm not a native speaker
008 Can't skip end credits BY DESIGN
009 Change doctorfargo to Ricky Derocher
010 Add Ricky Derocher and CassieBsg to beta testing

011 The sound volume doesn't work very well. This has two flavours : a) the sliders don't work very well. b) The tracks (MP3 files) are not very-well levelled
    - We need to check that all SFX files in the game have the proper "type" (music, sound, ambient)
    - Make sure that the volume of the SFX is not covered by the volume of the ambient, and vice versa
    - We rely a lot on the "defaultVolume" property but it seems that it is overridden as soon as we touch the general music volume slider.[/i]
012 Game crash after loading saved game (reported on Twitter) :
        Ultravariables line 204
        AGSCon4 line 110
        AGScon4 line 874
        AGSCon4 line 910
        Null pointer reference in 'on_event'

        Super weird! This is caused by the game failing to open Log.txt for writing to $APPDATADIR$. Maybe it was a one-time issue? Or he had broken permissions?
013 A guy on Facebook reported that the whole game flickers on screen, but he was unable to explain more and no one else saw that.
014 The "Down" arrow in the Dialog options GUI (to go down in the list of dialog answers) doesn't work. The "up" arrow works, though. Scrolling using the mouse wheel works too.

100 Change color "scroll up" / scrolldown" arrow sprites in dialogs
101 Change color theme of Tumbleweed GUI *change from blue to red)
       1400 to 1405 (inside AGS Editor : Main/00 GUI/thumbleweed) (In tumbleweed settongs: Verbs.VerbGuiOptions[eVerbGuiInvUparrowONsprite]  = 1402)
102 Apply good-looking 9-verb interface *can be found in other thread)
103 Cursor not blinking like it should (problem with view SCUMM_CURSOR not running properly?)
104 Delete option for "classic mode"
105 Add more colored backgrounds to more inventory items (at the moment only oil lamp has one)
106 Extra sprite for lit oil lamp

200 Indy sometimes gets stuck after an interaction. This is not entirely blocking as he can get unstuck by interacting with another hotspot. FIXED IN 1.1
201 Give more variety to the descriptions and/or names of the "skulls" hotspots in the catacombs
203 UI is briefly visible when dialog with monk is finished FIXED?
204 Monk has no mouth animation when saying "BEHOLD!" FIXED IN 1.1
205 Some voice acting? NOT FOR THE DEMO
206 Different music after Monk enters the room
207 Typos : "You chose/You choose", "Did he command" FIXED IN 1.1
208 Add a new hotspot for validating the skulls combination instead of letting it happen automatically
209 Tinted glass issue still present in RC2
210 Typo Can't you find the exit yourself?. <-- need to remove period at the end FIXED IN 1.1

300 Fix "wood" foosteps.
       The samples might be too short and confuse the AGS engine.
301 Name the hotspot at the main entrance
302 Re-introduce the rope puzzle?
303 When the basin is full, the walk-behind is not correct.
       Solution : Edit basin's animation 10 frames and add some pink to the top right
303 If you try using the gum on the font or on the door - it gives the LOOK description instead of a generic "That won't do any good message." TO TEST
304 Gum can be taken twice
304 It is not obvious that the first attempt at opening the furnace door (after using the oil) partially succeeds. Selmiak suggested a sound effect; Maybe we can make it even clearer.
305 Make horns play "POOO" from bottom to top instead of top to bottom, to avoid confusing the player.
306 Indy should be in front of the ghost NOT SURE I CAN DO THAT, not much room around the basin
307 The puzzle can be won with several combinations and even without the gum!
308 The Viking final cutscene is not very pretty
309 Some players try to push the door lock BEFORE opening the door
310 Some players try to insert various stuff into the holes in the stone in the church
311 Some players don't see the music notes towards the top of the screen

400 When walking away from hill, Indy floats some pixels above ground
401 Add some sound effects (shovel, ice crack...)
402 Make better/smaller hotspots for the fishermen village
403 Add explanation why Indy can't fill the bucket with snow IDEALLY HE COULD TRY FRESH WATER in the basin but that's a lot of extra work right now.
404 Wind ambient sound is annoying REMOVED
404 After removing the furnace door, if you point at the zone where the door used to be (thus after unhinging it), you still get an action verb highlighted (even though you can't interact with the zone anymore)

500 Sound effect when gem falls?
501 Add hotspot on viking ship

« Last Edit: May 03, 2020, 04:34:24 pm by jeancallisti »

Offline jeancallisti

  • Lead Artist
  • *****
  • Posts: 2179
  • I love Indy
    • View Profile
Re: Technical support for Relic of the Viking
« Reply #1 on: April 03, 2020, 11:14:21 pm »
Fixes that have been implemented in 1.1 so far :

- Language selection in-game at startup
- Special characters in opening and end credits (Tolga Öcek, hintergründe, etc.)
- Church's walkbehind fine-tuned when Indy walks down to the Fjord
- Church's and village's hotspots fine tuned (it confused a lot of people).
- Can no longer click on stuff during the main title cutscene in the catacombs
- fixed the "indy gets stuck, can no longer walk" bug in the catacombs
- Redesigned monk dialog puzzle to avoid players trying to brute-force it.

« Last Edit: April 11, 2020, 12:31:37 am by jeancallisti »

Offline jeancallisti

  • Lead Artist
  • *****
  • Posts: 2179
  • I love Indy
    • View Profile
Re: Technical support for Relic of the Viking
« Reply #2 on: April 17, 2020, 02:49:25 pm »
I'll start investigating how to make version 1.1 compatible with extra systems (Android? Mac/Linux?)

Offline jeancallisti

  • Lead Artist
  • *****
  • Posts: 2179
  • I love Indy
    • View Profile
Re: Technical support for Relic of the Viking
« Reply #3 on: May 24, 2020, 12:23:24 pm »
I've corrected a gazillion extra bugs and added some enhancements :
- oil lamp has a special sprite when lit.
- Fixed many missing interactions
- Fixed many "walk to" situations (to and from the harbour, to and from upstairs in the church)
- added au AUTOSAVE

And the one and only gigantic bug : There was not one, but two bugs related to the steam in the church. No wonder no one solved it they way it was intended... It's now fixed (at last).

As always, don't try to test them yourselves for now, they'll be in version 1.1
« Last Edit: May 24, 2020, 02:07:01 pm by jeancallisti »