Indiana Jones and the Seven Cities of Gold > Indiana Jones and the relic of the Viking

Hints and tips

(1/7) > >>

jeancallisti:
If you didn't get the steam puzzle, this is where you ask for some (not-too-obvious) hints  :hat:

Indy1960:
Hello,

thank you for the demo! Playing it, it awakens the feelings I had when playing the original games.

However, I'm stuck very early on and I'm not sure if it is just me or a technical bug. I have tried everything - but nothing works.

I'm in the church: I have everything: The broom stick, the chewing gum, the bucket, the long rudder. I have filled the basin, lit the oil lamp.

I could imagine that the next step is to play the "horn" (stone) which is placed at the right in the church. And I can imagine that you use the stick. But Indy wouldn't do it. I also realize that there are some musical notes at the top inside the church. It is also strange that I have to click "Use" twice (and Indy always says "I can't use it") before "Use ... with" appears.

It's frustrating: I have tried everything with everything - also in the mountain. Nothing works...

Help would be very much appreciated!

pali:
@Indy1960 Have you been at the harbour?

I - on the other hand - need help with the steam puzzle. I am clearly missing an indicator if I doing something right. I activated 4 and can't get the last one.

Cassiebsg:
@Indy1960

Hi, here's a couple hints and a solution.

Hint 1

Have you explored the harbour good enough? Have a feeling you might have missed something there.


Hint 2

There seems to be someone in the one of the boats.


Solution

Use Talk to on  the small boat/ship. :)


(hover the mouse over the text to read  :o )

Cassiebsg:
@pali

Hint:

You don't need the last one. There's a clue above the church's door.


(hover the mouse over the text to read  :o )

Navigation

[0] Message Index

[#] Next page

Go to full version